Changes

Jump to: navigation, search

Create macOS 12.0.1 bootable ISO

1,206 bytes added, 08:15, 10 November 2021
Created page with "Category:darwin == Introduction == First, we need to download the installer, then we need to create a .dng install media, and then we need to convert that to an ISO imag..."
[[Category:darwin]]

== Introduction ==

First, we need to download the installer, then we need to create a .dng install media, and then we need to convert that to an ISO image.

== Download the installer ==

softwareupdate --fetch-full-installer --full-installer-version 12.0.1

== Create the image ==

First, create a file-backed volume and mount it:

hdiutil create -o /tmp/macOS-12.0.1 -size 14000m -volname macOS-12.0.1 -layout SPUD -fs HFS+J
hdiutil attach /tmp/macOS-12.0.1.dmg -nobrowse -noverify -mountpoint /Volumes/macOS-12.0.1

Then format it again, yes, this seems to be required:

diskutil eraseDisk JHFS+ macOS-12.0.1 disk2

Then we can create the bootable image:

sudo /Applications/Install\ macOS\ Monterey.app/Contents/Resources/createinstallmedia --volume /Volumes/macOS-12.0.1 --nointeraction

Detach it:

hdiutil detach /Volumes/Install\ macOS\ Monterey/

And convert to ISO:

hdiutil convert /tmp/macOS-12.0.1.dmg -format UDTO -o macOS-12.0.1.cdr
mv macOS-12.0.1.cdr macOS-12.0.1.iso

No, it can't be done in a single step. After this, you can use this ISO in VMware.

== References ==

* [https://support.apple.com/en-us/HT201372 How to create a bootable installer for macOS]

Navigation menu